diff libpurple/protocols/oscar/Makefile.am @ 30361:9881f18b95b1

Got rid of family_icq.c -> oscar.c callbacks. Now it will be possible to add an error handler for SNAC_FAMILY_ICQ right inside family_icq.c, since all the necessary functions are there. I made a pretty large refactoring along the way, moving the authorization- and userinfo-related functions to separate files and renaming some of them. Hopefully, this will make oscar.c less of mess.
author ivan.komarov@soc.pidgin.im
date Sun, 30 May 2010 13:53:45 +0000
parents 7054f810b0f9
children 5bfef3338383
line wrap: on
line diff
--- a/libpurple/protocols/oscar/Makefile.am	Sat May 29 18:53:02 2010 +0000
+++ b/libpurple/protocols/oscar/Makefile.am	Sun May 30 13:53:45 2010 +0000
@@ -6,6 +6,7 @@
 pkgdir = $(libdir)/purple-$(PURPLE_MAJOR_VERSION)
 
 OSCARSOURCES = \
+	authorization.c     \
 	bstream.c           \
 	clientlogin.c       \
 	family_admin.c      \
@@ -44,6 +45,7 @@
 	snac.c              \
 	snactypes.h         \
 	tlv.c               \
+	userinfo.c          \
 	util.c
 
 AM_CFLAGS = $(st)