diff src/protocols/trepia/Makefile.am @ 5730:99ae9bd8b5fa

[gaim-migrate @ 6154] Added basic support for Trepia. Don't blame me if it doesn't work! It's a weird little system :) Use with caution in a fire-safe environment. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Wed, 04 Jun 2003 03:57:26 +0000
parents
children 2e23ccbccdec
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/protocols/trepia/Makefile.am	Wed Jun 04 03:57:26 2003 +0000
@@ -0,0 +1,30 @@
+pkgdir = $(libdir)/gaim
+
+TREPIASOURCES = \
+	md5.h \
+	profile.c \
+	profile.h \
+	trepia.c
+
+AM_CFLAGS = $(st)
+
+libtrepia_la_LDFLAGS = -module -avoid-version
+
+if STATIC_TREPIA
+
+st = -DSTATIC
+noinst_LIBRARIES = libtrepia.a
+libtrepia_a_SOURCES = $(TREPIASOURCES)
+libtrepia_a_CFLAGS  = $(AM_CFLAGS)
+
+else
+
+st =
+pkg_LTLIBRARIES   = libtrepia.la
+libtrepia_la_SOURCES = $(TREPIASOURCES)
+
+endif
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src \
+	$(DEBUG_CFLAGS)