diff configure.ac @ 3802:9bcb42faccc0

[gaim-migrate @ 3945] Rewrote show_im_dialog and show_info_dialog. Ported to gtkspell2. Gtkspell2 is a library available from gtkspell.sf.net. It requires the pspell library. If you want the "highlight misspelled words" feature to work, you must have this library installed. If installed, configure will detect it and link against it. committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Sat, 26 Oct 2002 06:41:13 +0000
parents 4fcd36091737
children 98faba851ea9
line wrap: on
line diff
--- a/configure.ac	Fri Oct 25 11:50:40 2002 +0000
+++ b/configure.ac	Sat Oct 26 06:41:13 2002 +0000
@@ -119,7 +119,7 @@
 
 AC_ARG_ENABLE(plugins, [  --disable-plugins       compile without plugin support],,enable_plugins=yes)
 AC_ARG_ENABLE(perl,    [  --disable-perl          compile without perl scripting],,enable_perl=yes)
-
+AC_ARG_ENABLE(gtkspell, [  --disable-gtkspell      compile without GtkSpell automatic spell checking],,enable_gtkspell=yes)
 AC_ARG_ENABLE(debug,   [  --enable-debug          compile with debugging support],,enable_debug=no)
 AC_ARG_ENABLE(screensaver,   [  --disable-screensaver   compile without X screensaver extension],,enable_xss=yes)
 AC_ARG_WITH(krb4,      [  --with-krb4=PREFIX      Compile Zephyr plugin with Kerberos 4 support],kerberos="$withval",kerberos="no")
@@ -211,6 +211,16 @@
 	fi
 fi
 
+dnl Thanks, Evan.
+if test "$enable_gtkspell" = yes ; then
+	PKG_CHECK_MODULES(GTKSPELL, gtkspell-2.0 >= 2.0.2, , enable_gtkspell=no)
+	if test "$enable_gtkspell" = "yes" ; then
+		AC_SUBST(GTKSPELL_CFLAGS)
+		AC_SUBST(GTKSPELL_LIBS)
+        	AC_DEFINE(USE_GTKSPELL,,[do we have gtkspell?])
+	fi
+fi
+
 if test "$enable_nas" = yes ; then
 	AC_DEFINE(NAS_SOUND, 1, [Define if we have NAS sound support.])
         SOUND_LIBS="-laudio -lXt"
@@ -382,6 +392,8 @@
 echo Build with Plugin support..... : $enable_plugins
 echo Build with Perl support....... : $enable_perl
 echo
+echo Build with GtkSpell............: $enable_gtkspell
+echo
 echo Use XScreenSaver Extension.... : $enable_xss
 echo
 echo Build with ESD................ : $enable_esd