diff configure.ac @ 4561:9df99116840a

[gaim-migrate @ 4842] This is the new sound subsystem Lots of stuff got renamed, and everything sound-wise is documented. Gaim now uses libaudiofile and libao to play sounds. Lots of ugly hacks were removed, and now we support playing audio through anything that libao will support. If you need to (you shouldn't) you can force libao to use a specific output driver, by putting a line into ~/.libao like: default_driver=esd You shouldn't need to do this, libao is pretty good at figuring out what driver to use. committer: Tailor Script <tailor@pidgin.im>
author Nathan Walp <nwalp@pidgin.im>
date Sun, 09 Feb 2003 01:55:35 +0000
parents fbf9f873abfc
children 27354602734d
line wrap: on
line diff
--- a/configure.ac	Sun Feb 09 00:47:57 2003 +0000
+++ b/configure.ac	Sun Feb 09 01:55:35 2003 +0000
@@ -122,10 +122,7 @@
 AC_DEFINE_UNQUOTED(STATIC_PROTO_INIT, $extern_init void static_proto_init() { $load_proto },
 	[Loads static protocol plugin module initialization functions.])
 
-AC_ARG_ENABLE(esd,     [  --disable-esd           Turn off ESD (default=auto)],,enable_esd=yes)
-AC_ARG_ENABLE(nas,     [  --enable-nas            Enable NAS (Network Audio System) support],,enable_nas=no)
-AC_ARG_ENABLE(artsc,   [  --disable-artsc         Turn off ArtsC (default=auto)],,enable_artsc=yes)
-
+AC_ARG_ENABLE(audio,   [  --disable-audio         compile without libao/libaudiofile for sound playing],,enable_audio=yes)
 AC_ARG_ENABLE(plugins, [  --disable-plugins       compile without plugin support],,enable_plugins=yes)
 AC_ARG_ENABLE(perl,    [  --disable-perl          compile without perl scripting],,enable_perl=yes)
 AC_ARG_ENABLE(gtkspell, [  --disable-gtkspell      compile without GtkSpell automatic spell checking],,enable_gtkspell=yes)
@@ -274,45 +271,22 @@
 	fi
 fi
 
-if test "$enable_nas" = yes ; then
-	AC_DEFINE(NAS_SOUND, 1, [Define if we have NAS sound support.])
-        SOUND_LIBS="-laudio -lXt"
-fi
-if test "$enable_esd" = yes ; then
-	AM_PATH_GESD
-        if test "$no_esd" != yes ; then
-		old_CFLAGS="$CFLAGS"
-        	CFLAGS="$CFLAGS $ESD_CFLAGS"
-		AC_TRY_COMPILE(,[#include <esd.h>],
-			[
-				AC_DEFINE(ESD_SOUND, 1, [Define if we have ESD sound support.])
-				SOUND_LIBS="$SOUND_LIBS $ESD_LIBS"
-			],[
-				enable_esd=no
-				CFLAGS="$old_CFLAGS"
-			])
+if test "$enable_audio" = yes ; then
+	GAIM_PATH_AO(found_ao_lib=true)
+
+	AM_PATH_AUDIOFILE([0.2.0], found_af_lib=true)
+
+	if test "$found_ao_lib" = "true" -a "$found_af_lib" = "true"; then
+		SOUND_LIBS="$AO_LIBS $AUDIOFILE_LIBS"
+		AC_SUBST(SOUND_LIBS)
+		AC_DEFINE(USE_AO, 1, [Define if we're using libao and libaudiofile for sound playing])
+		enable_audio=yes
 	else
-		enable_esd=no
-        fi
+		enable_audio=no
+	fi
+else
+	enable_audio=no
 fi
-if test "x$enable_artsc" = "xyes"; then
-	AM_PATH_ARTSC
-	if test "x$no_artsc" != "xyes" ; then
-		old_CFLAGS="$CFLAGS"
-		CFLAGS="$CFLAGS $ARTSC_CFLAGS"
-		AC_TRY_COMPILE(,[#include <artsc.h>],
-			[
-				AC_DEFINE(ARTSC_SOUND, 1, [Define if we have artsc sound support.])
-				SOUND_LIBS="$SOUND_LIBS $ARTSC_LIBS"
-			],[
-				enable_artsc=no
-				CFLAGS="$old_CFLAGS"
-			])
-	else
-		enable_artsc=no
-	fi
-fi
-AC_SUBST(SOUND_LIBS)
 
 if test "$ac_cv_cygwin" = yes ; then
 	LDADD="$LDADD -static"
@@ -443,20 +417,16 @@
 echo Build Protocol Plugins........ : $enable_prpls
 echo Protocols to link statically.. : $STATIC_PRPLS
 echo
-echo UI Library.................... : GTK 2.0
+echo UI Library.................... : GTK 2.x
 echo
 echo Build with Plugin support..... : $enable_plugins
 echo Build with Perl support....... : $enable_perl
-echo
-echo Build with GtkSpell............: $enable_gtkspell
+echo Build with Audio support...... : $enable_audio
+echo Build with GtkSpell support... : $enable_gtkspell
 echo
 echo Use XScreenSaver Extension.... : $enable_xss
 echo Use X Session Management...... : $enable_sm
 echo
-echo Build with ESD................ : $enable_esd
-echo Build with NAS................ : $enable_nas
-echo Build with ArtsC.............. : $enable_artsc
-echo
 echo Print debugging messages...... : $enable_debug
 echo
 eval eval echo Gaim will be installed in $bindir.