diff plugins/Makefile.am @ 591:a26eb4c472d8

[gaim-migrate @ 601] plugins makefile script works better. perl is getting added to. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Thu, 03 Aug 2000 02:05:26 +0000
parents d7cdcd9e28f4
children a3fe1e6f4946
line wrap: on
line diff
--- a/plugins/Makefile.am	Wed Aug 02 19:15:13 2000 +0000
+++ b/plugins/Makefile.am	Thu Aug 03 02:05:26 2000 +0000
@@ -1,15 +1,7 @@
-if GNOMEAPPLET
-CFLAGS += $(GTK_CFLAGS) $(GNOME_INCLUDEDIR) -I../src -DUSE_APPLET
-else
-CFLAGS += $(GTK_CFLAGS) -I../src -I../libfaim/faim -I../libfaim
-endif
-
-
-
-LDFLAGS += -ggdb $(GTK_LIBS) -shared
+LDFLAGS += $(LIBS) -ggdb -shared
 SUFFIXES = .c .so
 .c.so:
-	$(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -fPIC -DPIC -o $@ $< $(LDFLAGS) $(PLUGIN_LIBS)
+	$(CC) $(CFLAGS) -I../src -DVERSION=\"$(VERSION)\" -fPIC -DPIC -o $@ $< $(LDFLAGS) $(PLUGIN_LIBS)