diff plugins/mono/Makefile.am @ 11660:a3302d271199

[gaim-migrate @ 13945] Thanks to the hard work of Eoin 'ecoffey' Coffey, here is the mono plugin loader. It needs a lot of api wrapping a bit more autotools loving, but with the basic API that is wrapped, it works quite well. committer: Tailor Script <tailor@pidgin.im>
author Gary Kramlich <grim@reaperworld.com>
date Fri, 14 Oct 2005 05:00:17 +0000
parents
children 4117f696638e
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/plugins/mono/Makefile.am	Fri Oct 14 05:00:17 2005 +0000
@@ -0,0 +1,15 @@
+SUBDIRS = api loader
+
+TARGETS = MPlugin.dll GetBuddyBack.dll
+
+all: $(TARGETS)
+	
+install-exec-am:
+	$(INSTALL) -m 644 $(TARGETS) $(libdir)/gaim
+
+clean-generic:
+	rm -rf $(TARGETS)
+
+SUFFIXES = .cs .dll
+.cs.dll:
+	mcs -t:library -lib:./api -out:$*.dll -r:GaimAPI.dll $*.cs