diff configure.ac @ 27434:a7d2bc001b6b

Fix some quoting for AC_LANG_PROGRAM.
author Elliott Sales de Andrade <qulogic@pidgin.im>
date Sat, 11 Jul 2009 06:49:43 +0000
parents 0491bd8a2a60
children 35cb9aa9eb2f
line wrap: on
line diff
--- a/configure.ac	Sat Jul 11 06:46:21 2009 +0000
+++ b/configure.ac	Sat Jul 11 06:49:43 2009 +0000
@@ -1731,8 +1731,8 @@
 	LIBS="$LIBS $GNUTLS_LIBS"
 	CPPFLAGS_save="$CPPFLAGS"
 	CPPFLAGS="$CPPFLAGS $GNUTLS_CFLAGS"
-	AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <gnutls/gnutls.h>],
-                                        [gnutls_session s; gnutls_priority_set_direct(s, NULL, NULL);])],
+	AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <gnutls/gnutls.h>]],
+                                        [[gnutls_session s; gnutls_priority_set_direct(s, NULL, NULL);]])],
 	               [AC_DEFINE([HAVE_GNUTLS_PRIORITY_FUNCS], 1,
                                   [Define if your gnutls has gnutls_priority_set_direct and friends])
 	                AC_MSG_RESULT(yes)],
@@ -2027,9 +2027,9 @@
 	LIBS="$LIBS $NSS_LIBS"
 	CPPFLAGS_save="$CPPFLAGS"
 	CPPFLAGS="$CPPFLAGS $NSS_CFLAGS"
-	AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <nss.h>
-#include <secmod.h>],
-                                        [NSS_SetAlgorithmPolicy(SEC_OID_MD2, 0, 0);])],
+	AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <nss.h>
+#include <secmod.h>]],
+                                        [[NSS_SetAlgorithmPolicy(SEC_OID_MD2, 0, 0);]])],
 	               [AC_DEFINE([NEED_NSS_WEAK_ALGORITHMS], 1,
                                   [Define if your NSS needs weak algorithms activated with NSS_SetAlgorithmPolicy])
 	                AC_MSG_RESULT(yes)],