diff configure.ac @ 21303:a9482e431e43

propagate from branch 'org.maemo.garage.pidgin.pidgin.blist-show-with-parent' (head 9dc35209de2406ba1fbc9a266b4e931ff6ebd80a) to branch 'im.pidgin.pidgin' (head 9e5e4cdd0ee1212ba93c50907b439a9aa222bee9)
author Ethan Blanton <elb@pidgin.im>
date Sat, 10 Nov 2007 17:39:31 +0000
parents 5b1acbab99cf
children abbf74f4732b
line wrap: on
line diff
--- a/configure.ac	Sat Nov 10 15:02:13 2007 +0000
+++ b/configure.ac	Sat Nov 10 17:39:31 2007 +0000
@@ -2003,9 +2003,12 @@
 if test "x$enable_plugins" = "xyes" ; then
 	AC_DEFINE(PURPLE_PLUGINS, 1, [Define if plugins are enabled.])
 	AM_CONDITIONAL(PLUGINS, true)
+	PLUGINS_DEFINE="#define PURPLE_PLUGINS 1"
 else
 	AM_CONDITIONAL(PLUGINS, false)
+	PLUGINS_DEFINE="#undef PURPLE_PLUGINS"
 fi
+AC_SUBST(PLUGINS_DEFINE)
 
 dnl #######################################################################
 dnl # Check for Cyrus-SASL (for Jabber)
@@ -2272,6 +2275,7 @@
 		   libpurple/protocols/yahoo/Makefile
 		   libpurple/protocols/zephyr/Makefile
 		   libpurple/tests/Makefile
+		   libpurple/purple.h
 		   libpurple/version.h
 		   share/Makefile
 		   share/sounds/Makefile