diff configure.ac @ 28006:aa098151ca49

applied changes from c55cc517cc0bc09b677222a63f5f466531033719 through 51ea62d1cdee93a0f6ab96f22d28cbe07ea5d13b Plucked revision 51ea62d1cdee93a0f6ab96f22d28cbe07ea5d13b from im.pidgin.pidgin.2.6.1 Original commit message: Make sure configure checks for glib and gtk 2.4.0, since that's what is needed to compile. We took a small vote on IRC or in the jabber room and we all thought it would be fine to do this rather than try to make stuff work. We'll see how it goes.
author Mark Doliner <mark@kingant.net>
date Wed, 19 Aug 2009 07:39:52 +0000
parents 584e063285b7
children 9fa1de6d508a
line wrap: on
line diff
--- a/configure.ac	Wed Aug 19 01:03:47 2009 +0000
+++ b/configure.ac	Wed Aug 19 07:39:52 2009 +0000
@@ -312,11 +312,11 @@
 dnl #######################################################################
 dnl # Check for GLib 2.0 (required)
 dnl #######################################################################
-PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.0.0 gobject-2.0 gmodule-2.0 gthread-2.0], , [
+PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.4.0 gobject-2.0 gmodule-2.0 gthread-2.0], , [
 	AC_MSG_RESULT(no)
 	AC_MSG_ERROR([
 
-You must have the GLib 2.0 development headers installed to build.
+You must have GLib 2.4.0 or newer development headers installed to build.
 
 If you have these installed already you may need to install pkg-config so
 I can find them.
@@ -399,12 +399,13 @@
 fi
 
 if test "x$enable_gtkui" = "xyes" ; then
-	PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.0.0], , [
+	PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.4.0], , [
 		AC_MSG_RESULT(no)
 		AC_MSG_ERROR([
 
-You must have the GTK+ 2.0 development headers installed to compile Pidgin.
-If you want to build only Finch then specify --disable-gtkui when running configure.
+You must have GTK+ 2.4.0 or newer development headers installed to compile
+Pidgin.  If you want to build only Finch then specify --disable-gtkui when
+running configure.
 ])])
 
 	AC_SUBST(GTK_CFLAGS)