diff plugins/Makefile.am @ 2893:abf9303fb328

[gaim-migrate @ 2906] yeah, yeah, yeah committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Sun, 16 Dec 2001 21:11:12 +0000
parents b10dbe7de693
children be601eb50d0a
line wrap: on
line diff
--- a/plugins/Makefile.am	Sun Dec 16 21:07:48 2001 +0000
+++ b/plugins/Makefile.am	Sun Dec 16 21:11:12 2001 +0000
@@ -2,7 +2,7 @@
 SUFFIXES = .c .so
 .c.so:
 	$(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -c $< -o tmp$@.lo $(PLUGIN_CFLAGS)
-	$(LIBTOOL) --mode=link    $(CC) $(CFLAGS) -o libtmp$@.la -rpath $(plugindir) tmp$@.lo $(LIBS) $(LDFLAGS) -avoid-version $(PLUGIN_LIBS)
+	$(LIBTOOL) --mode=link    $(CC) $(CFLAGS) -o libtmp$@.la -rpath $(plugindir) tmp$@.lo $(LIBS) $(LDFLAGS) -module -avoid-version $(PLUGIN_LIBS)
 	@rm -f tmp$@.lo tmp$@.o libtmp$@.la
 	@cp .libs/libtmp$@.so* $@
 	@rm -f .libs/libtmp$@.*