diff configure.ac @ 13746:ae1849182c8f

[gaim-migrate @ 16157] Make our configure.ac autodetect Avahi's Howl compatibility library, and fallback to using Howl if Avahi isn't installed. Also fixed specifying a lib directory for Howl. committer: Tailor Script <tailor@pidgin.im>
author Mark Doliner <mark@kingant.net>
date Mon, 08 May 2006 04:32:21 +0000
parents 889ad72bc16e
children 463259ea22ff
line wrap: on
line diff
--- a/configure.ac	Mon May 08 04:02:50 2006 +0000
+++ b/configure.ac	Mon May 08 04:32:21 2006 +0000
@@ -194,9 +194,8 @@
 HOWL_CFLAGS=""
 HOWL_LIBS=""
 
-dnl Attempt to autodetect Howl
-dnl TODO Check avahi-compat-howl!!!
-PKG_CHECK_MODULES(HOWL, howl, [
+dnl Attempt to autodetect avahi-compat-howl
+PKG_CHECK_MODULES(HOWL, avahi-compat-howl, [
 		howlincludes="yes"
 		howllibs="yes"
 	], [
@@ -205,6 +204,18 @@
 		howllibs="no"
 	])
 
+dnl Attempt to autodetect Howl
+if test "x$howlincludes" = "xno"; then
+	PKG_CHECK_MODULES(HOWL, howl, [
+			howlincludes="yes"
+			howllibs="yes"
+		], [
+			AC_MSG_RESULT(no)
+			howlincludes="no"
+			howllibs="no"
+		])
+fi
+
 dnl Override HOWL_CFLAGS if the user specified an include dir
 if test "$ac_howl_includes" != "no"; then
 	HOWL_CFLAGS="-I$ac_howl_includes"
@@ -216,7 +227,7 @@
 
 dnl Override HOWL_LIBS if the user specified a libs dir
 if test "$ac_howl_libs" != "no"; then
-	HOWL_LIBS="-L$ac_howl_libs"
+	HOWL_LIBS="-L$ac_howl_libs -lhowl"
 fi
 AC_CHECK_LIB(howl, sw_discovery_init, [howllibs=yes], [howllibs=no], $HOWL_LIBS)