diff libgaim/protocols/gg/Makefile.am @ 14650:aeff2dd10462

[gaim-migrate @ 17396] Old automake prefers this way of conditionally building the bundled libgadu. committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Fri, 29 Sep 2006 12:57:29 +0000
parents 1e1bcb4a6d82
children 69590c55c748
line wrap: on
line diff
--- a/libgaim/protocols/gg/Makefile.am	Fri Sep 29 06:15:53 2006 +0000
+++ b/libgaim/protocols/gg/Makefile.am	Fri Sep 29 12:57:29 2006 +0000
@@ -15,20 +15,8 @@
 
 pkgdir = $(libdir)/gaim
 
-GGSOURCES = \
-	gg-utils.h \
-	gg-utils.c \
-	confer.h \
-	confer.c \
-	search.h \
-	search.c \
-	buddylist.h \
-	buddylist.c \
-	gg.h \
-	gg.c
-
 if USE_INTERNAL_LIBGADU
-GGSOURCES += \
+INTGGSOURCES = \
 	lib/common.c \
 	lib/compat.h \
 	lib/dcc.c \
@@ -44,6 +32,19 @@
 INTGG_CFLAGS = -I$(top_srcdir)/libgaim/protocols/gg/lib
 endif
 
+GGSOURCES = \
+	$(INTGGSOURCES) \
+	gg-utils.h \
+	gg-utils.c \
+	confer.h \
+	confer.c \
+	search.h \
+	search.c \
+	buddylist.h \
+	buddylist.c \
+	gg.h \
+	gg.c
+
 AM_CFLAGS = $(st)
 
 libgg_la_LDFLAGS = -module -avoid-version $(GLIB_LIBS)