diff libpurple/protocols/null/Makefile.am @ 17373:afee8b840d91

this patch adds nullprpl, a mock protocol plugin, to the libpurple/protocols directory Closes #811 committer: Richard Laager <rlaager@wiktel.com>
author Ryan Barrett <ryanbarrett@users.sourceforge.net>
date Wed, 30 May 2007 01:21:36 +0000
parents
children 2b62300d2c19
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/libpurple/protocols/null/Makefile.am	Wed May 30 01:21:36 2007 +0000
@@ -0,0 +1,21 @@
+EXTRA_DIST = README Makefile.mingw
+
+pkgdir = $(libdir)/purple-$(PURPLE_MAJOR_VERSION)
+
+NULLSOURCES = nullprpl.c
+
+AM_CFLAGS = $(st)
+
+libnull_la_LDFLAGS = -module -avoid-version
+
+# nullprpl isn't built by default. when it is built, it's dynamically linked.
+st =
+pkg_LTLIBRARIES   = libnull.la
+libnull_la_SOURCES = $(NULLSOURCES)
+libnull_la_LIBADD  = $(GLIB_LIBS)
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/libpurple \
+	-I$(top_builddir)/libpurple \
+	$(GLIB_CFLAGS) \
+	$(DEBUG_CFLAGS)