diff configure.ac @ 13465:b03f19de58b8

[gaim-migrate @ 15840] * Use GADU_CFLAGS when checking for compatibility of libgadu with the GPL. * Try to display buddy's alias when asking user for a chatroom. * Added myself to the Help->About dialog. committer: Tailor Script <tailor@pidgin.im>
author Bartoz Oler <bartosz@pidgin.im>
date Wed, 08 Mar 2006 21:25:19 +0000
parents c1f5d9858c1d
children 40c5d0508a1a
line wrap: on
line diff
--- a/configure.ac	Wed Mar 08 21:13:37 2006 +0000
+++ b/configure.ac	Wed Mar 08 21:25:19 2006 +0000
@@ -317,6 +317,8 @@
 
 if test "x$gadu_libs" = "xyes"; then
 	AC_MSG_CHECKING(for libgadu GPL compatibility)
+	CPPFLAGS_save="$CPPFLAGS"
+	CPPFLAGS="$CPPFLAGS $GADU_CFLAGS"
 	AC_TRY_COMPILE([#include <libgadu.h>], [
 #ifdef __GG_LIBGADU_HAVE_OPENSSL
 #error "libgadu is not compatible with the GPL when compiled with OpenSSL support."
@@ -339,6 +341,7 @@
 		GADU_CFLAGS=""
 		gadu_libs=no
 	])
+	CPPFLAGS="$CPPFLAGS_save"
 fi
 
 AC_SUBST(GADU_LIBS)