diff configure.ac @ 3572:bdd0bebd2d04

[gaim-migrate @ 3670] Phase II. No longer do you have to worry about protocol plugins. When Gaim probes plugins on load, it will detect protocol plugins and add them to the list of available protocols. When you try to log an account on with one of them, Gaim will automatically load the plugin--when no more accounts need the protocol--Gaim will automatically unload it. Protocol plugins are no longer available in the plugins ui, and no protocols are compiled statically by default. committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Mon, 30 Sep 2002 01:05:18 +0000
parents cd938f18f3f8
children 2e681e84dd79
line wrap: on
line diff
--- a/configure.ac	Sun Sep 29 17:00:14 2002 +0000
+++ b/configure.ac	Mon Sep 30 01:05:18 2002 +0000
@@ -67,7 +67,7 @@
 AM_CONDITIONAL(DISTRIB, test "x$enable_distrib" = "xyes")
 AC_ARG_ENABLE(multi,   [  --disable-multi         disable multiple connections],,enable_multi=yes)
 AC_ARG_ENABLE(prpls,   [  --disable-prpls         don't build dynamic protocol plugins],,enable_prpls=yes)
-AC_ARG_WITH(static-prpls,    [  --with-static-prpls     link in certain protocols statically],[STATIC_PRPLS=`echo $withval | $sedpath 's/,/ /g'`],STATIC_PRPLS="oscar")
+AC_ARG_WITH(static-prpls,    [  --with-static-prpls     link in certain protocols statically],[STATIC_PRPLS=`echo $withval | $sedpath 's/,/ /g'`],STATIC_PRPLS="")
 if test "x$STATIC_PRPLS" = "xall" ; then
 	STATIC_PRPLS="gg irc jabber msn napster oscar toc yahoo zephyr"
 fi
@@ -78,7 +78,7 @@
 for i in $STATIC_PRPLS ; do
 	STATIC_LINK_LIBS="$STATIC_LINK_LIBS protocols/$i/lib$i.a"
 	extern_init="$extern_init extern void ${i}_init(struct prpl *);"
-	load_proto="$load_proto load_protocol(${i}_init, sizeof(struct prpl));"
+	load_proto="$load_proto load_protocol(${i}_init);"
 	case $i in
 		gg) static_gg=yes ;;
 		irc) static_irc=yes ;;