diff configure.in @ 4429:bf770f11132b

[gaim-migrate @ 4704] (15:41:59) Robot101: the hunk that got left out in the cold. its a good thing when things compile committer: Tailor Script <tailor@pidgin.im>
author Luke Schierer <lschiere@pidgin.im>
date Sun, 26 Jan 2003 20:41:49 +0000
parents 3270d3536e12
children 801830dec409
line wrap: on
line diff
--- a/configure.in	Sun Jan 26 19:39:43 2003 +0000
+++ b/configure.in	Sun Jan 26 20:41:49 2003 +0000
@@ -112,16 +112,13 @@
 AC_DEFINE_UNQUOTED(STATIC_PROTO_INIT, $extern_init void static_proto_init() { $load_proto },
 	[Loads static protocol plugin module initialization functions.])
 
-AC_ARG_ENABLE(esd,     [  --disable-esd           Turn off ESD (default=auto)],,enable_esd=yes)
-AC_ARG_ENABLE(nas,     [  --enable-nas            Enable NAS (Network Audio System) support],,enable_nas=no)
-AC_ARG_ENABLE(artsc,   [  --disable-artsc         Turn off ArtsC (default=auto)],,enable_artsc=yes)
-
+AC_ARG_ENABLE(audio,   [  --disable-audio         compile without libao/libaudiofile for sound playing],,enable_audio=yes)
 AC_ARG_ENABLE(plugins, [  --disable-plugins       compile without plugin support],,enable_plugins=yes)
 AC_ARG_ENABLE(perl,    [  --disable-perl          compile without perl scripting],,enable_perl=yes)
 AC_ARG_ENABLE(gtkspell, [  --disable-gtkspell      compile without GtkSpell automatic spell checking],,enable_gtkspell=yes)
-
 AC_ARG_ENABLE(debug,   [  --enable-debug          compile with debugging support],,enable_debug=no)
 AC_ARG_ENABLE(screensaver,   [  --disable-screensaver   compile without X screensaver extension],,enable_xss=yes)
+AC_ARG_ENABLE(sm,      [  --disable-sm            compile without X session management support],,enable_sm=yes)
 AC_ARG_WITH(krb4,      [  --with-krb4=PREFIX      Compile Zephyr plugin with Kerberos 4 support],kerberos="$withval",kerberos="no")
 
 if test "$enable_debug" = yes ; then
@@ -248,45 +245,28 @@
 	fi
 fi
 
-if test "$enable_nas" = yes ; then
-	AC_DEFINE(NAS_SOUND, 1, [Define if we have NAS sound support.])
-        SOUND_LIBS="-laudio -lXt"
-fi
-if test "$enable_esd" = yes ; then
-	AM_PATH_GESD
-        if test "$no_esd" != yes ; then
-		old_CFLAGS="$CFLAGS"
-        	CFLAGS="$CFLAGS $ESD_CFLAGS"
-		AC_TRY_COMPILE(,[#include <esd.h>],
-			[
-				AC_DEFINE(ESD_SOUND, 1, [Define if we have ESD sound support.])
-				SOUND_LIBS="$SOUND_LIBS $ESD_LIBS"
-			],[
-				enable_esd=no
-				CFLAGS="$old_CFLAGS"
-			])
+if test "$enable_audio" = yes ; then
+	AC_CHECK_HEADERS(ao/ao.h, found_ao_lib=true, found_ao_lib=false)
+	if test "$found_ao_lib" = "true"; then
+		AC_CHECK_LIB(ao, ao_initialize, found_ao_lib=true, found_ao_lib=false)
+	fi
+
+	AC_CHECK_HEADERS(audiofile.h, found_af_lib=true, found_af_lib=false)
+	if test "$found_af_lib" = "true"; then
+		AC_CHECK_LIB(audiofile, afOpenFile, found_af_lib=true, found_af_lib=false)
+	fi
+
+	if test "$found_ao_lib" = "true" -a "$found_af_lib" = "true"; then
+		SOUND_LIBS="-lao -laudiofile"
+		AC_SUBST(SOUND_LIBS)
+		AC_DEFINE(USE_AO, 1, [Define if we're using libao and libaudiofile for sound playing])
+		enable_audio=yes
 	else
-		enable_esd=no
-        fi
+		enable_audio=no
+	fi
+else
+	enable_audio=no
 fi
-if test "x$enable_artsc" = "xyes"; then
-	AM_PATH_ARTSC
-	if test "x$no_artsc" != "xyes" ; then
-		old_CFLAGS="$CFLAGS"
-		CFLAGS="$CFLAGS $ARTSC_CFLAGS"
-		AC_TRY_COMPILE(,[#include <artsc.h>],
-			[
-				AC_DEFINE(ARTSC_SOUND, 1, [Define if we have artsc sound support.])
-				SOUND_LIBS="$SOUND_LIBS $ARTSC_LIBS"
-			],[
-				enable_artsc=no
-				CFLAGS="$old_CFLAGS"
-			])
-	else
-		enable_artsc=no
-	fi
-fi
-AC_SUBST(SOUND_LIBS)
 
 if test "$ac_cv_cygwin" = yes ; then
 	LDADD="$LDADD -static"
@@ -418,18 +398,15 @@
 echo Build Protocol Plugins........ : $enable_prpls
 echo Protocols to link statically.. : $STATIC_PRPLS
 echo
-echo UI Library.................... : GTK 2.0
+echo UI Library.................... : GTK 2.x
 echo
 echo Build with Plugin support..... : $enable_plugins
 echo Build with Perl support....... : $enable_perl
-echo
-echo Build with GtkSpell............: $enable_gtkspell
+echo Build with Audio support...... : $enable_audio
+echo Build with GtkSpell support... : $enable_gtkspell
 echo
 echo Use XScreenSaver Extension.... : $enable_xss
-echo
-echo Build with ESD................ : $enable_esd
-echo Build with NAS................ : $enable_nas
-echo Build with ArtsC.............. : $enable_artsc
+echo Use X Session Management...... : $enable_sm
 echo
 echo Print debugging messages...... : $enable_debug
 echo