diff libpurple/Makefile.am @ 27711:c1314a6cefcf

Automatically detect if running under valgrind and don't close plugin modules so that valgrind can resolve symbols and report where the leaks are
author Stu Tomlinson <stu@nosnilmot.com>
date Tue, 28 Jul 2009 01:23:39 +0000
parents 7fbf964c6c6c
children 77423ba51dd4
line wrap: on
line diff
--- a/libpurple/Makefile.am	Tue Jul 28 01:18:46 2009 +0000
+++ b/libpurple/Makefile.am	Tue Jul 28 01:23:39 2009 +0000
@@ -151,6 +151,7 @@
 	theme-manager.h \
 	upnp.h \
 	util.h \
+	valgrind.h \
 	value.h \
 	xmlnode.h \
 	whiteboard.h
@@ -273,7 +274,8 @@
 	$(dbus_sources)
 
 noinst_HEADERS= \
-	internal.h 
+	internal.h \
+	valgrind.h
 
 libpurpleincludedir=$(includedir)/libpurple
 libpurpleinclude_HEADERS = \