diff src/Makefile.am @ 10245:c143a3fac58d

[gaim-migrate @ 11385] Binary relocation, step one. I had a fairly long commit message, and cvs ate it and said Read from remote host cvs.sourceforge.net: Connection reset by peer I'm displeased. This is just method one, method two to follow tomorrow after I add a way to register a fallback and try to push it upstream. That way I don't have to put method 2 inside prefix.c. As for as core/ui split goes, they can either each have their own copy after the divorce is final, or the UI can use the core's. It'll work either way, since #1 finds location of the caller, and #2 doesn't work on libraries anyway. That's one advantage I forgot to mention, btw, that #1 will let a library find its own location. So, I'm sure something isn't quite right and someone will want to fix it. So they can fix it while i implement phase two. Which won't take long at all, but the autopackage guy is in bed, and I should be too. committer: Tailor Script <tailor@pidgin.im>
author Tim Ringenbach <marv@pidgin.im>
date Tue, 23 Nov 2004 05:53:59 +0000
parents 37c411c8cde3
children 0cf2a686266e
line wrap: on
line diff
--- a/src/Makefile.am	Tue Nov 23 02:49:09 2004 +0000
+++ b/src/Makefile.am	Tue Nov 23 05:53:59 2004 +0000
@@ -81,9 +81,10 @@
 	plugin.c \
 	pluginpref.c \
 	pounce.c \
+	prefix.c \
+	prefs.c \
 	privacy.c \
 	proxy.c \
-	prefs.c \
 	prpl.c \
 	request.c \
 	roomlist.c \
@@ -119,9 +120,10 @@
 	plugin.h \
 	pluginpref.h \
 	pounce.h \
+	prefix.h
+	prefs.h \
 	privacy.h \
 	proxy.h \
-	prefs.h \
 	prpl.h \
 	request.h \
 	roomlist.h \
@@ -225,7 +227,9 @@
 	$(STARTUP_NOTIFICATION_LIBS)
 
 gaim_remote_SOURCES = \
-	gaim-remote.c
+	gaim-remote.c \
+	prefix.c \
+	prefix.h
 
 gaim_remote_DEPENDENCIES = @LIBOBJS@
 gaim_remote_LDADD = \
@@ -233,6 +237,7 @@
 	$(top_builddir)/plugins/gaim-remote/libgaim-remote.la
 
 AM_CPPFLAGS = \
+	-DBR_PTHREADS=0 \
 	-DDATADIR=\"$(datadir)\" \
 	-DLIBDIR=\"$(libdir)/gaim/\" \
 	-DLOCALEDIR=\"$(datadir)/locale\" \