diff configure.ac @ 11903:c9312177821a

[gaim-migrate @ 14194] "make distcheck" fixes - mostly fixing DBUS things so they can compile outside the source tree, and a few compile warning fixes. committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Sun, 30 Oct 2005 17:24:38 +0000
parents f3a0cefa8e35
children 3edbb29daa0c
line wrap: on
line diff
--- a/configure.ac	Sun Oct 30 17:23:15 2005 +0000
+++ b/configure.ac	Sun Oct 30 17:24:38 2005 +0000
@@ -418,12 +418,11 @@
 if test "x$enable_dbus" = "xyes" ; then
     AC_MSG_CHECKING([location of the D-BUS session directory])
     if ! test -z "$with_dbus_session_dir"; then
-      	if ! test -d "$with_dbus_session_dir"; then
-	    AC_MSG_WARN([$with_dbus_session_dir does not exist, if this is the correct location please make sure that it exists.])
-	    enable_dbus=no
-	fi
-
-	DBUS_SESSION_DIR="$with_dbus_session_dir"
+		if ! test -d "$with_dbus_session_dir"; then
+			AC_MSG_WARN([$with_dbus_session_dir does not exist, if this is the correct location please make sure that it exists.])
+			enable_dbus=no
+		fi
+		DBUS_SESSION_DIR="$with_dbus_session_dir"
     else
 	dnl # add more to this as needed
 	servicesprefixes="$DATADIR $LIBDIR /usr/share /usr/local/share"
@@ -442,8 +441,6 @@
 	    enable_dbus=no
 	fi
     fi
-
-
 fi
 
 if test "x$enable_dbus" = "xyes" ; then