diff plugins/Makefile.am @ 11903:c9312177821a

[gaim-migrate @ 14194] "make distcheck" fixes - mostly fixing DBUS things so they can compile outside the source tree, and a few compile warning fixes. committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Sun, 30 Oct 2005 17:24:38 +0000
parents 85c0aece7be9
children 9096f56b725f
line wrap: on
line diff
--- a/plugins/Makefile.am	Sun Oct 30 17:23:15 2005 +0000
+++ b/plugins/Makefile.am	Sun Oct 30 17:24:38 2005 +0000
@@ -90,8 +90,8 @@
 $(top_builddir)/src/dbus-types.h: always
 	cd $(@D) && $(MAKE) $(AM_MAKEFLAGS) $(@F)
 
-dbus-example-bindings.c: $(top_srcdir)/src/dbus-analyze-functions.py $(dbus_example_la_SOURCES) $(dbus_example_la_HEADERS)
-	cat $(dbus_example_la_SOURCES) $(dbus_example_la_HEADERS) | \
+dbus-example-bindings.c: $(top_srcdir)/src/dbus-analyze-functions.py $(dbus_example_la_SOURCES)
+	cat $(srcdir)/$(dbus_example_la_SOURCES) | \
 	$(PYTHON) $(top_srcdir)/src/dbus-analyze-functions.py --export-only > $@
 
 $(dbus_example_la_OBJECTS) dbus-example.so: dbus-example-bindings.c $(top_builddir)/src/dbus-types.h
@@ -105,9 +105,14 @@
 	ChangeLog HOWTO \
 	ChangeLog.API \
 	Makefile.mingw \
+	contact_priority.c \
 	filectl.c \
 	fortuneprofile.pl \
 	gaim.pl \
+	gaiminc.c \
+	gtk-signals-test.c \
+	ipc-test-client.c \
+	ipc-test-server.c \
 	mailchk.c \
 	pluginpref_example.c \
 	raw.c \
@@ -117,6 +122,7 @@
 AM_CPPFLAGS = \
 	-DDATADIR=\"$(datadir)\" \
 	-DVERSION=\"$(VERSION)\" \
+	-I$(top_builddir)/src \
 	-I$(top_srcdir)/src \
 	$(DEBUG_CFLAGS) \
 	$(GTK_CFLAGS) \