diff plugins/Makefile.am @ 176:c99d0b82c8a8

[gaim-migrate @ 186] Fixed a bug where if you unload a plugin that had 3 callbacks, it would only unload 2 of them. Other touch-ups and additions. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Tue, 25 Apr 2000 18:55:56 +0000
parents 4b011ba81a9d
children 8d8faeab01f6
line wrap: on
line diff
--- a/plugins/Makefile.am	Tue Apr 25 17:38:35 2000 +0000
+++ b/plugins/Makefile.am	Tue Apr 25 18:55:56 2000 +0000
@@ -1,5 +1,9 @@
 SUFFIXES = .c .so
-CFLAGS += $(GTK_CFLAGS) -I../src $(GAIM_CFLAGS)
+if GNOMEAPPLET
+CFLAGS += $(GTK_CFLAGS) -I../src -DUSE_APPLET
+else
+CFLAGS += $(GTK_CFLAGS) -I../src
+endif
 LDFLAGS += -ggdb $(GTK_LIBS) -shared
 .c.so:
 	$(CC) $(CFLAGS) -Wl,-soname,$@ -o $@ $< $(LDFLAGS)