diff configure.ac @ 4298:cddb50734169

[gaim-migrate @ 4552] faceprint cleans up after my messes committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Sat, 11 Jan 2003 19:59:27 +0000
parents 280ed2b617be
children 16540914c963
line wrap: on
line diff
--- a/configure.ac	Sat Jan 11 16:47:58 2003 +0000
+++ b/configure.ac	Sat Jan 11 19:59:27 2003 +0000
@@ -240,6 +240,16 @@
 	dnl This is almost definitely wrong, but in case there's
 	dnl something I'm missing, I'll leave it in.
 	AC_CHECK_FUNCS(Perl_eval_pv)
+
+	AC_MSG_CHECKING(for old perl)
+	PERL_OLD=`$perlpath -e 'if($]<5.006){printf"yes\n";}else{printf"no\n";}'`
+
+	if test "$PERL_OLD" = "yes"; then
+		AC_DEFINE(OLD_PERL, 1, [Define if old perl is installed.])
+		AC_MSG_RESULT(yes)
+	else
+		AC_MSG_RESULT(no)
+	fi
 else
 	PERL_CFLAGS=
 	PERL_LIBS=