diff libpurple/Makefile.am @ 16583:ce049678a67b

soname versioning of libpurple. Should help resolve debian bug 421282 All version control is within configure.ac now Adjust the define for purple_version_suffix as appropriate: [devel] - normal development periods [betaN] - for beta releases [] - for releases Follow the instructions in configure.ac to set the version number depending on how the API has changed (ie. following our normal version numbering!) version.h is auto-generated now Added purple_version_check(), purple_major_version, purple_minor_version, & purple_micro_version for run-time version comparisons in addition to the existing compile time macros. libpurple Plugins moved again, this time to: $(libdir)/purple-$PURPLE_MAJOR_VERSION This will allow parallel installations of different major libpurple versions in the future should someone wish to.
author Stu Tomlinson <stu@nosnilmot.com>
date Sat, 28 Apr 2007 16:55:31 +0000
parents 7125eda8fe22
children 171acd9ebb1a
line wrap: on
line diff
--- a/libpurple/Makefile.am	Sat Apr 28 12:58:16 2007 +0000
+++ b/libpurple/Makefile.am	Sat Apr 28 16:55:31 2007 +0000
@@ -8,6 +8,7 @@
 		purple-url-handler \
 		purple.pc.in \
 		purple-uninstalled.pc.in \
+		version.h.in \
 		Makefile.mingw \
 		win32/global.mak \
 		win32/libc_interface.c \
@@ -75,6 +76,7 @@
 	upnp.c \
 	util.c \
 	value.c \
+	version.c \
 	xmlnode.c \
 	whiteboard.c
 
@@ -219,7 +221,7 @@
 	$(dbus_headers)
 
 libpurple_la_DEPENDENCIES = $(STATIC_LINK_LIBS)
-libpurple_la_LDFLAGS = -export-dynamic
+libpurple_la_LDFLAGS = -export-dynamic -version-info $(LT_VERSION_INFO) -no-undefined
 libpurple_la_LIBADD = \
 	$(DBUS_LIBS) \
 	$(GLIB_LIBS) \
@@ -232,7 +234,7 @@
 AM_CPPFLAGS = \
 	-DBR_PTHREADS=0 \
 	-DDATADIR=\"$(datadir)\" \
-	-DLIBDIR=\"$(libdir)/purple/\" \
+	-DLIBDIR=\"$(libdir)/purple-$(PURPLE_MAJOR_VERSION)/\" \
 	-DLOCALEDIR=\"$(datadir)/locale\" \
 	-DSYSCONFDIR=\"$(sysconfdir)\" \
 	$(GLIB_CFLAGS) \