diff configure.ac @ 14600:d44c87d17b19

[gaim-migrate @ 17327] Fall back to using internal libgadu if an external one is not found committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Wed, 20 Sep 2006 11:42:26 +0000
parents bcf89a7c69db
children 1e1bcb4a6d82
line wrap: on
line diff
--- a/configure.ac	Wed Sep 20 09:13:17 2006 +0000
+++ b/configure.ac	Wed Sep 20 11:42:26 2006 +0000
@@ -652,6 +652,8 @@
 	CPPFLAGS="$CPPFLAGS_save"
 fi
 
+AM_CONDITIONAL(USE_INTERNAL_LIBGG, test "x$gadu_libs" != "xyes")
+
 AC_SUBST(GADU_LIBS)
 AC_SUBST(GADU_CFLAGS)
 
@@ -676,9 +678,6 @@
 if test "x$silcincludes" != "xyes" -o "x$silcclient" != "xyes"; then
 	STATIC_PRPLS=`echo $STATIC_PRPLS | $sedpath 's/silc//'`
 fi
-if test "x$gadu_libs" != "xyes"; then
-	STATIC_PRPLS=`echo $STATIC_PRPLS | $sedpath 's/gg//'`
-fi
 AC_SUBST(STATIC_PRPLS)
 STATIC_LINK_LIBS=
 extern_init=
@@ -741,9 +740,6 @@
 if test "x$silcincludes" != "xyes" -o "x$silcclient" != "xyes"; then
 	DYNAMIC_PRPLS=`echo $DYNAMIC_PRPLS | $sedpath 's/silc//'`
 fi
-if test "x$gadu_libs" != "xyes"; then
-	DYNAMIC_PRPLS=`echo $DYNAMIC_PRPLS | $sedpath 's/gg//'`
-fi
 AC_SUBST(DYNAMIC_PRPLS)
 for i in $DYNAMIC_PRPLS ; do
 	case $i in