diff configure.ac @ 28857:d4814f2afaef

*** Plucked rev 8afdf9fa3c0c98a6735023230f285152f54c3a79 (f05c54b03e6bbfdbff38c01697fbd353a969e05e): Swap the order of -L and -l so that Solaris can find the Python libraries. Patch from Paul \"aab\" Townsend. Closes #10869, #10716.
author Daniel Atallah <daniel.atallah@gmail.com>
date Thu, 07 Jan 2010 23:42:06 +0000
parents abf5d79dd87d
children 47672ba67bae
line wrap: on
line diff
--- a/configure.ac	Thu Jan 07 23:41:17 2010 +0000
+++ b/configure.ac	Thu Jan 07 23:42:06 2010 +0000
@@ -1470,7 +1470,7 @@
 		AC_CHECK_LIB(pthread, pthread_create, )
 		AC_CHECK_LIB(util, openpty, )
 		AC_CHECK_LIB(db, dbopen, )
-		PY_LIBS="-lpython$PY_VERSION -L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
+		PY_LIBS="-L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config -lpython$PY_VERSION"
 		PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
 		AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.])
 		AC_MSG_RESULT(ok)