diff configure.ac @ 17177:d761647bc7c4

merge of '0a63bea05479d51972432a195d0c97c0309fbcf4' and '8ff17e25184faaad69c1329218cd6898bc3e4c26'
author Eric Polino <aluink@pidgin.im>
date Sun, 13 May 2007 21:27:13 +0000
parents 555469b10122
children 92f7afd6c640 a770353e7306
line wrap: on
line diff
--- a/configure.ac	Tue May 08 02:44:49 2007 +0000
+++ b/configure.ac	Sun May 13 21:27:13 2007 +0000
@@ -139,6 +139,19 @@
 ALL_LINGUAS="af am ar az bg bn bs ca ca@valencia cs da de dz el en_AU en_CA en_GB eo es et eu fa fi fr gl gu he hi hu id it ja ka kn ko ku lt mk my_MM nb ne nl nn pa pl pt_BR pt ps ro ru sk sl sq sr sr@Latn sv ta te th tr uk vi xh zh_CN zh_HK zh_TW"
 AM_GLIB_GNU_GETTEXT
 
+dnl If we don't have msgfmt, then po/ is going to fail -- ensure that
+dnl AM_GLIB_GNU_GETTEXT found it.
+
+if test x$MSGFMT = xno -o x$GMSGFMT = x
+then
+	AC_ERROR([
+
+The msgfmt command is required to build libpurple.  If it is installed
+on your system, ensure that it is in your path.  If it is not, install
+GNU gettext to continue.
+])
+fi
+
 dnl we don't use autobreak on cygwin!!
 dnl AC_CYGWIN
 
@@ -892,22 +905,7 @@
 AC_CHECK_HEADER(sys/utsname.h)
 AC_CHECK_FUNC(uname)
 
-AC_ARG_ENABLE(fortify, [AC_HELP_STRING([--disable-fortify], [compile without FORTIFY_SOURCE support])], enable_fortify="$enableval", enable_fortify=yes)
-
-AC_ARG_ENABLE(mcheck, [AC_HELP_STRING([--enable-mcheck], [compile with mcheck (malloc debugging) support])], enable_mcheck="$enableval", enable_mcheck="$enable_debug")
-if test "x$enable_mcheck" = "xyes" ; then
-	orig_LIBS="$LIBS"
-	LIBS="$LIBS -lmcheck"
-	AC_MSG_CHECKING(for mcheck support)
-	AC_TRY_COMPILE([], [
-		int main() {return 0;}
-	], [
-		AC_MSG_RESULT(yes)
-	], [
-		AC_MSG_RESULT(no)
-		LIBS="$orig_LIBS"
-	])
-fi
+AC_ARG_ENABLE(fortify, [AC_HELP_STRING([--disable-fortify], [compile without FORTIFY_SOURCE support])], , enable_fortify=yes)
 
 if test "x$GCC" = "xyes"; then
 	dnl We enable -Wall later.
@@ -1987,16 +1985,11 @@
 
 AC_ARG_ENABLE(debug, [AC_HELP_STRING([--enable-debug],
 	[compile with debugging support])], , enable_debug=no)
+
 if test "x$enable_debug" = "xyes" ; then
 	AC_DEFINE(DEBUG, 1, [Define if debugging is enabled.])
 fi
 
-AC_ARG_ENABLE(fatal-asserts, [AC_HELP_STRING([--enable-fatal-asserts],
-	[make assertions fatal (useful for debugging)])], , enable_fatal_asserts=no)
-if test "x$enable_fatal_asserts" = "xyes" ; then
-	AC_DEFINE(PURPLE_FATAL_ASSERTS, 1, [Define to make assertions fatal (useful for debugging).])
-fi
-
 AC_OUTPUT([Makefile
 		   Doxyfile
 		   doc/Makefile
@@ -2145,7 +2138,6 @@
 echo Build with Tk support......... : $enable_tk
 echo
 echo Print debugging messages...... : $enable_debug
-echo Assertions are fatal.......... : $enable_fatal_asserts
 echo
 eval eval echo Pidgin will be installed in $bindir.
 if test "x$pidginpath" != "x" ; then