diff libpurple/protocols/qq/Makefile.am @ 24322:d971d5369b43

2008.10.30 - flos <lonicerae(at)gmail.com> * Fixed a bug which made xgettext failed in buddy_info.c * Fixed a bug in Makefile.am and Makefile.mingw * Updated acknowledgement in qq.c
author SHiNE CsyFeK <csyfek@gmail.com>
date Thu, 30 Oct 2008 12:41:36 +0000
parents 1ee91ff0d5fe
children fecedf6d9ee1
line wrap: on
line diff
--- a/libpurple/protocols/qq/Makefile.am	Tue Oct 28 16:59:07 2008 +0000
+++ b/libpurple/protocols/qq/Makefile.am	Thu Oct 30 12:41:36 2008 +0000
@@ -54,9 +54,13 @@
 libqq_la_LDFLAGS = -module -avoid-version
 
 CURRENT_REVISION=$(shell \
-		 awk 'BEGIN {"grep node .hg_archival.txt" | getline rev; \
-		 rev=substr(rev,7,6); \
-		 print rev}')
+		 if [ -e ./.hg_archival.txt ]; then \
+		   awk 'BEGIN {"grep node .hg_archival.txt" | getline rev; \
+		   rev=substr(rev,7,6); print rev}' > current_revision; \
+		 else \
+		   echo "!hg" > current_revision; \
+		 fi; \
+		 cat ./current_revision)
 
 if STATIC_QQ