diff Makefile.am @ 21567:d98b612d3f75

merge of '936967b97a8afdc95b54fe92924ef7c0414bea42' and 'd04590ee7402c6c27ab86cb88f9b1d579c20c5dd'
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Sat, 17 Nov 2007 02:20:01 +0000
parents a97f24eda509
children 19ad2242c06d
line wrap: on
line diff
--- a/Makefile.am	Wed Nov 14 02:40:56 2007 +0000
+++ b/Makefile.am	Sat Nov 17 02:20:01 2007 +0000
@@ -42,12 +42,19 @@
 GNT_DIR=finch
 endif
 
-SUBDIRS = libpurple doc $(GNT_DIR) $(GTK_DIR) m4macros po share
+SUBDIRS = libpurple doc $(GNT_DIR) $(GTK_DIR) m4macros po share/ca-certs share/sounds
 
 docs: Doxyfile
 if HAVE_DOXYGEN
 	@echo "Running doxygen..."
 	@doxygen
+if HAVE_XSLTPROC
+	@echo "Generating devhelp index..."
+	@xsltproc doxy2devhelp.xsl doc/xml/index.xml > doc/html/pidgin.devhelp
+	@echo "(Symlink doc/html to ~/.local/share/gtk-doc/html/pidgin to make devhelp see the documentation)"
+else
+	@echo "Not generating devhelp index: xsltproc was not found by configure"
+endif
 else
 	@echo "doxygen was not found during configure.  Aborting."
 	@echo;