diff libpurple/plugins/Makefile.am @ 16784:db06d4a18246

Add a python script plugins/startup.py which will first check whether a client with the same home directory is running. If so, it will do a purple_blist_show() and exit. Otherwise, it will start the client. Usage example: startup.py pidgin -c /tmp/ I wanted to do a purple_notify_ to notify the user. But because we can't/ don't expose functions with callbacks as parameters to dbus, that was not possible.
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Wed, 02 May 2007 16:18:45 +0000
parents dc6903cc63b3
children 02867a434634
line wrap: on
line diff
--- a/libpurple/plugins/Makefile.am	Wed May 02 16:14:09 2007 +0000
+++ b/libpurple/plugins/Makefile.am	Wed May 02 16:18:45 2007 +0000
@@ -122,7 +122,8 @@
 	filectl.c \
 	fortuneprofile.pl \
 	ipc-test-client.c \
-	ipc-test-server.c
+	ipc-test-server.c \
+	startup.py
 
 AM_CPPFLAGS = \
 	-DDATADIR=\"$(datadir)\" \