diff libpurple/Makefile.am @ 23797:e1c8ec1259de

Updates voice and video to use Farsight 2, gets XMPP voice conferences closer to XEP-0167, and fixes a lot of bugs.
author Mike Ruprecht <maiku@soc.pidgin.im>
date Fri, 23 May 2008 02:42:32 +0000
parents 92e71f6e10d4
children f47be691e588
line wrap: on
line diff
--- a/libpurple/Makefile.am	Sun Apr 13 17:53:46 2008 +0000
+++ b/libpurple/Makefile.am	Fri May 23 02:42:32 2008 +0000
@@ -1,6 +1,7 @@
 EXTRA_DIST = \
 		dbus-analyze-functions.py \
 		dbus-analyze-types.py \
+		marshallers.list \
 		purple-notifications-example \
 		purple-remote \
 		purple-send \
@@ -51,6 +52,7 @@
 	idle.c \
 	imgstore.c \
 	log.c \
+	marshallers.c \
 	media.c \
 	mediamanager.c \
 	mime.c \
@@ -105,6 +107,7 @@
 	idle.h \
 	imgstore.h \
 	log.h \
+	marshallers.h \
 	media.h \
 	mediamanager.h \
 	mime.h \
@@ -139,6 +142,14 @@
 
 purple_builtheaders = purple.h version.h
 
+marshallers.h: marshallers.list
+	@echo "Generating marshallers.h"
+	$(GLIB_GENMARSHAL) --prefix=purple_smarshal $(srcdir)/marshallers.list --header > marshallers.h
+
+marshallers.c: marshallers.list
+	@echo "Generating marshallers.c"
+	$(GLIB_GENMARSHAL) --prefix=purple_smarshal $(srcdir)/marshallers.list --body > marshallers.c
+
 if ENABLE_DBUS
 
 CLEANFILES = \
@@ -147,6 +158,8 @@
 	dbus-client-binding.h \
 	dbus-types.c \
 	dbus-types.h \
+	marshallers.c \
+	marshallers.h \
 	purple-client-bindings.c \
 	purple-client-bindings.h \
 	purple.service
@@ -217,6 +230,8 @@
 	dbus-types.c \
 	dbus-types.h \
 	dbus-bindings.c \
+	marshallers.c \
+	marshallers.h \
 	purple-client-bindings.c \
 	purple-client-bindings.h