diff libpurple/plugins/ssl/Makefile.am @ 24294:e39cafdbe089

Only build SSL plugins if the corresponding library is present. Previously, stub versions of the plugins were built which refused to load if the corresponding library was missing, which seems ... unconventional to me.
author Will Thompson <will.thompson@collabora.co.uk>
date Sat, 25 Oct 2008 14:33:54 +0000
parents 441945083737
children bcad7dc4b453
line wrap: on
line diff
--- a/libpurple/plugins/ssl/Makefile.am	Sat Oct 25 14:26:30 2008 +0000
+++ b/libpurple/plugins/ssl/Makefile.am	Sat Oct 25 14:33:54 2008 +0000
@@ -9,10 +9,31 @@
 
 if PLUGINS
 
+# I'm sorry to report that Automake Conditionals don't support
+#   if USE_GNUTLS && USE_NSS
+# but only support testing a single variable. Hence:
+
+if USE_GNUTLS
+if USE_NSS
 plugin_LTLIBRARIES = \
 	ssl.la           \
 	ssl-gnutls.la    \
 	ssl-nss.la
+else
+plugin_LTLIBRARIES = \
+	ssl.la           \
+	ssl-gnutls.la
+endif
+else
+if USE_NSS
+plugin_LTLIBRARIES = \
+	ssl.la           \
+	ssl-nss.la
+else
+plugin_LTLIBRARIES = \
+	ssl.la
+endif
+endif
 
 ssl_la_SOURCES        = ssl.c
 ssl_gnutls_la_SOURCES = ssl-gnutls.c