diff configure.ac @ 22576:e4b2cbc246da

I'm tired of installing pixmap data that almost never changes. I'm so tired of it, in fact, that I decided to add the ability to disable pixmap installation to our configure script. For the two of us that actually wanted it, here it is.
author John Bailey <rekkanoryo@rekkanoryo.org>
date Sun, 30 Mar 2008 00:19:07 +0000
parents 9693a727e7ef
children 0085d8b80bc4
line wrap: on
line diff
--- a/configure.ac	Sat Mar 29 19:14:17 2008 +0000
+++ b/configure.ac	Sun Mar 30 00:19:07 2008 +0000
@@ -2144,6 +2144,13 @@
 AC_SUBST(CHECK_LIBS)
 
 dnl #######################################################################
+dnl # Disable pixmap installation
+dnl #######################################################################
+AC_ARG_ENABLE(pixmaps-install, AC_HELP_STRING([--enable-pixmaps-install], [enable installation of pixmap files]), enable_pixmaps="$enableval", enable_pixmaps=yes)
+
+AM_CONDITIONAL(INSTALL_PIXMAPS, test "x$enable_pixmaps" = "xyes")
+
+dnl #######################################################################
 dnl # Check for Doxygen and dot (part of GraphViz)
 dnl #######################################################################
 AC_ARG_ENABLE(doxygen,
@@ -2300,6 +2307,7 @@
 echo Build with Cyrus SASL support. : $enable_cyrus_sasl
 echo Use kerberos 4 with zephyr.... : $kerberos
 echo Use external libzephyr........ : $zephyr
+echo Install pixmaps............... : $enable_pixmaps
 echo Has you....................... : yes
 echo
 echo Use XScreenSaver Extension.... : $enable_screensaver