diff plugins/perl/Makefile.am @ 6665:e5c7149bc9ed

[gaim-migrate @ 7190] Perl seems to pass make distcheck now. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 31 Aug 2003 22:43:50 +0000
parents 95652c05c7ae
children 7a0c324276ba
line wrap: on
line diff
--- a/plugins/perl/Makefile.am	Sun Aug 31 21:41:37 2003 +0000
+++ b/plugins/perl/Makefile.am	Sun Aug 31 22:43:50 2003 +0000
@@ -58,7 +58,12 @@
 	$(common_sources)
 
 common/Makefile: common/Makefile.PL
-	cd common && $(perlpath) Makefile.PL $(PERL_MM_PARAMS)
+	@if test "x${top_srcdir}" != "x${top_builddir}"; then \
+		for f in ${common_sources}; do \
+			${LN_S} -f ../${srcdir}/$$f $$f; \
+		done; \
+	fi
+	@cd common && $(perlpath) Makefile.PL $(PERL_MM_PARAMS)
 
 common/Makefile.PL: common/Makefile.PL.in $(top_srcdir)/config.status
 	cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
@@ -73,6 +78,11 @@
 		 $(MAKE) CC="$(CC)" CCFLAGS="$(PERL_CFLAGS) $(CFLAGS)" $(PERL_EXTRA_OPTS)) && \
 		cd ..; \
 	done
+	@if test "x${top_srcdir}" != "x${top_builddir}"; then \
+		for f in ${common_sources}; do \
+			rm -f $$f; \
+		done; \
+	fi
 
 install-exec-local:
 	@for dir in $(perl_dirs); do \