diff configure.ac @ 3382:e9a89676d120

[gaim-migrate @ 3401] No longer do we build libicq.so -- run make in src/protocols/icq if you feel you need it for some reason (you don't--use OSCAR) TOC is no longer compiled statically by default. If you need it for some reason, you can load the libtoc.so plugin. Ari Pollak fixed up some #ifdefs to get IM images to work in gtk2, and he fixed a few gtk font warnings elsewhere. committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Wed, 07 Aug 2002 23:25:33 +0000
parents b1cdee27ef02
children bfed0b1ac718
line wrap: on
line diff
--- a/configure.ac	Wed Aug 07 22:37:58 2002 +0000
+++ b/configure.ac	Wed Aug 07 23:25:33 2002 +0000
@@ -68,7 +68,7 @@
 AC_ARG_ENABLE(prpls,   [  --disable-prpls         don't build dynamic protocol plugins],,enable_prpls=yes)
 AC_ARG_WITH(static-prpls,    [  --with-static-prpls     link in certain protocols statically],[STATIC_PRPLS=`echo $withval | $sedpath 's/,/ /g'`],STATIC_PRPLS="oscar toc")
 if test "x$STATIC_PRPLS" = "xall" ; then
-	STATIC_PRPLS="gg icq irc jabber msn napster oscar toc yahoo zephyr"
+	STATIC_PRPLS="gg irc jabber msn napster oscar toc yahoo zephyr"
 fi
 AC_SUBST(STATIC_PRPLS)
 STATIC_LINK_LIBS=
@@ -80,7 +80,6 @@
 	load_proto="$load_proto load_protocol(${i}_init, sizeof(struct prpl));"
 	case $i in
 		gg) static_gg=yes ;;
-		icq) static_icq=yes ;;
 		irc) static_irc=yes ;;
 		jabber) static_jabber=yes ;;
 		msn) static_msn=yes ;;
@@ -93,7 +92,6 @@
 	esac
 done
 AM_CONDITIONAL(STATIC_GG, test "x$static_gg" = "xyes")
-AM_CONDITIONAL(STATIC_ICQ, test "x$static_icq" = "xyes")
 AM_CONDITIONAL(STATIC_IRC, test "x$static_irc" = "xyes")
 AM_CONDITIONAL(STATIC_JABBER, test "x$static_jabber" = "xyes")
 AM_CONDITIONAL(STATIC_MSN, test "x$static_msn" = "xyes")