diff configure.ac @ 12685:e9f279f0ef02

[gaim-migrate @ 15028] Changes from and inspired by SF Patch #1394379 from Martijn Dekker "The attached patch to configure.ac fixes two issues: (1) To compile Gaim 2.0.0cvs on Mac OS X, the linker flag "-lresolv" is needed to correctly link to the libresolv library, or the linker will complain about an illegal indirect reference to "res_9_dn_expand" in src/dnssrv.c. (2) On Mac OS X with Fink, the /sw/include and /sw/lib paths need to be included in CPPFLAGS and LDFLAGS respectively for configure to detect certain libraries such as libao and GNUTLS." I took a different (and untested) approach to solving the first one. As for the second, we were already doing CFLAGS, so I only accepted the LDFLAGS part. committer: Tailor Script <tailor@pidgin.im>
author Richard Laager <rlaager@wiktel.com>
date Mon, 02 Jan 2006 23:07:46 +0000
parents 0f8b80dc9647
children e5f79b206d7e
line wrap: on
line diff
--- a/configure.ac	Mon Jan 02 09:01:52 2006 +0000
+++ b/configure.ac	Mon Jan 02 23:07:46 2006 +0000
@@ -21,10 +21,12 @@
 # before gettexting, in case iconv matters
 case "$host_os" in
 darwin*)
+	AC_CHECK_LIB(resolv, res_query)
 	AC_MSG_CHECKING([for fink])
 	if test -d /sw; then
 		AC_MSG_RESULT([found, adding /sw to search paths])
 		CFLAGS="$CFLAGS -I/sw/include"
+		LDFLAGS="$LDFLAGS -L/sw/lib"
 	else
 		AC_MSG_RESULT([not found])
 	fi