diff Makefile.am @ 606:eaab8abda2c0

[gaim-migrate @ 616] ok, a few changes. 1) --enable-gnome (which is the default) can make sounds go through gnome, which means they're configurable. they can still go through gaim. 2) --enable-gnome will also install the necessary files to make sounds through gnome work. 3) the rpm will be built without gnome; if a distributor later wants to require gnome that's up to them. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Fri, 04 Aug 2000 17:13:54 +0000
parents 9ec08f6bb944
children f9b9e3751e89
line wrap: on
line diff
--- a/Makefile.am	Fri Aug 04 05:36:02 2000 +0000
+++ b/Makefile.am	Fri Aug 04 17:13:54 2000 +0000
@@ -15,12 +15,33 @@
 gaimdesktopdir = $(gnomedata)/applets/Network
 gaimdesktop_DATA = $(gaim_DESKTOP)
 
-gaim_SOUND = gaim_applet.soundlist
+gaim_SOUND = gaim.soundlist
 gaimsounddir = $(gnomesysconf)/sound/events
 gaimsound_DATA = $(gaim_SOUND)
 
 endif
 
+if DISTRIB
+
+distribgnorbadir = $(sysconfdir)/CORBA/servers
+distribgnorba_DATA = gaim_applet.gnorba
+
+distribdesktopdir = $(datadir)/applets/Network
+distribdesktop_DATA = gaim_applet.desktop
+
+distribsounddir = $(sysconfdir)/sound/events
+distribsound_DATA = gaim.soundlist
+
+endif
+
+if GNOMEBITS
+
+bitssysconf = `@GNOME_CONFIG@ --sysconfdir`
+bitssounddir = $(bitssysconf)/sound/events
+bitssound_DATA = gaim.soundlist
+
+endif
+
 pixmapdir = $(datadir)/gnome/apps/Internet
 pixmap_DATA = gaim.desktop