diff plugins/Makefile.am @ 1047:ece2d1543b20

[gaim-migrate @ 1057] Plugins now use GModule. Protocol plugins can be dynamically updated. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Wed, 01 Nov 2000 22:30:36 +0000
parents 1c663beef29d
children 49799527aebf
line wrap: on
line diff
--- a/plugins/Makefile.am	Wed Nov 01 11:34:56 2000 +0000
+++ b/plugins/Makefile.am	Wed Nov 01 22:30:36 2000 +0000
@@ -1,13 +1,14 @@
-LDFLAGS += $(LDADD) $(LIBS) -shared
+LDFLAGS += $(LDADD) $(LIBS) -ggdb -shared
+CFLAGS += -DHAVE_CONFIG_H
 SUFFIXES = .c .so
 .c.so:
-	$(CC) $(CFLAGS) -I../src -DVERSION=\"$(VERSION)\" -fPIC -o $@ $< $(LDFLAGS) $(PLUGIN_LIBS)
+	$(CC) $(CFLAGS) -I../src -DVERSION=\"$(VERSION)\" -o $@ $< $(LDFLAGS) $(PLUGIN_LIBS)
 
 if PLUGINS
 plugin_DATA = autorecon.so iconaway.so notify.so spellchk.so lagmeter.so
 plugindir = $(libdir)/gaim
 
-clean distclean clean-recursive distclean-recursive:
+clean distclean:
 	$(RM) $(plugin_DATA)
 endif