diff libpurple/tests/Makefile.am @ 31204:f1874b08b3f9

Add unit tests for oscar_util_name_compare. I suspected that this function missed a few cases, but I was wrong, it's good. I used ck_assert_int_eq and ck_assert_ne, which look like they might be newer API. If that causes a problem we can change them to fail_if and fail_unless
author Mark Doliner <mark@kingant.net>
date Mon, 14 Feb 2011 03:10:09 +0000
parents e743507b3767
children 81a2ec76c285
line wrap: on
line diff
--- a/libpurple/tests/Makefile.am	Mon Feb 14 01:01:37 2011 +0000
+++ b/libpurple/tests/Makefile.am	Mon Feb 14 03:10:09 2011 +0000
@@ -14,6 +14,7 @@
 		test_jabber_digest_md5.c \
 		test_jabber_jutil.c \
 		test_jabber_scram.c \
+		test_oscar_util.c \
 		test_qq.c \
 		test_yahoo_util.c \
 		test_util.c \
@@ -30,6 +31,7 @@
 
 check_libpurple_LDADD=\
 		$(top_builddir)/libpurple/protocols/jabber/libjabber.la \
+		$(top_builddir)/libpurple/protocols/oscar/liboscar.la \
 		$(top_builddir)/libpurple/protocols/qq/libqq_tmp.la \
 		$(top_builddir)/libpurple/protocols/yahoo/libymsg.la \
 		$(top_builddir)/libpurple/libpurple.la \