diff libpurple/gconf/Makefile.am @ 29929:f2fba90f6ce7

Fix installing GConf schema. GCONF_SCHEMAS_INSTALL does not refer to whether the file should be installed on the filesystem or not. This is still broken for people who disable i18n but no more than before.
author Stu Tomlinson <stu@nosnilmot.com>
date Thu, 13 May 2010 13:28:12 +0000
parents f7d03842b9c9
children
line wrap: on
line diff
--- a/libpurple/gconf/Makefile.am	Thu May 13 05:11:00 2010 +0000
+++ b/libpurple/gconf/Makefile.am	Thu May 13 13:28:12 2010 +0000
@@ -2,17 +2,17 @@
 
 EXTRA_DIST = purple.schemas.in
 
-if GCONF_SCHEMAS_INSTALL
-
 if INSTALL_I18N
 schema_in_files = purple.schemas.in
 schema_DATA = $(schema_in_files:.schemas.in=.schemas)
 @INTLTOOL_SCHEMAS_RULE@
-endif #INSTALL_I18N
 
+if GCONF_SCHEMAS_INSTALL
 install-data-local:
 	GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1 | \
 		grep -v "^WARNING: failed to install schema" | grep -v "^Attached schema" 1>&2
 else
 install-data-local:
 endif #GCONF_SCHEMAS_INSTALL
+
+endif #INSTALL_I18N