diff configure.ac @ 8919:f37992e86e66

[gaim-migrate @ 9689] " Very simple patch that stores the arguments given to configure into config.h.. for example './configure --enable-debug' will set CONFIG_ARGS to "'--enable-debug'". This works just like php does when you do a phpinfo();" --Gary Kramlich the only real point of this is that it helps 3rd party plugin people in the case that the person installing said plugin compiled, or at least configured, gaim. but it shouldn't hurt anything either so... committer: Tailor Script <tailor@pidgin.im>
author Luke Schierer <lschiere@pidgin.im>
date Wed, 12 May 2004 03:42:13 +0000
parents a11807af171e
children f15fcdbecf0a
line wrap: on
line diff
--- a/configure.ac	Wed May 12 03:38:48 2004 +0000
+++ b/configure.ac	Wed May 12 03:42:13 2004 +0000
@@ -8,6 +8,9 @@
 
 AC_PATH_PROG(sedpath, sed)
 
+dnl Storing configure arguments
+AC_DEFINE_UNQUOTED(CONFIG_ARGS, "$ac_configure_args", [configure arguments])
+
 dnl Checks for programs.
 AC_PROG_CC
 AC_DISABLE_STATIC