diff finch/libgnt/wms/Makefile.am @ 19168:f63e38e33811

Some lines to the auto-thingies to aid in libgnt building standalone
author Eric Polino <aluink@pidgin.im>
date Mon, 16 Jul 2007 19:49:59 +0000
parents 1bccb9641ef3
children 315151da0dc6 635b7cd19110
line wrap: on
line diff
--- a/finch/libgnt/wms/Makefile.am	Fri Jul 13 18:19:55 2007 +0000
+++ b/finch/libgnt/wms/Makefile.am	Mon Jul 16 19:49:59 2007 +0000
@@ -1,10 +1,16 @@
+if PURPLE_AVAILABLE
+# These custom wms depend on libpurple
+purple_wms = s.la irssi.la
+else
+purple_wms =
+endif
+
 s_la_LDFLAGS             = -module -avoid-version
 irssi_la_LDFLAGS         = -module -avoid-version
 
 plugin_LTLIBRARIES = \
-	s.la \
-	irssi.la
-
+	$(purple_wms)
+ 
 plugindir = $(libdir)/gnt
 
 irssi_la_SOURCES = irssi.c