Mercurial > pidgin
view gaim.spec @ 142:fbabd28795d2
[gaim-migrate @ 152]
Added auto-load for plugins. Rob pointed out this might be a bad idea: what
if plugins modify the buddy list; the plugins are loaded before signon, thus
before the buddy list appears. That would cause errors; then when the list
does appear, the plugin doesn't work right because it didn't start off well.
My response:
EWarmenhoven: there are ways around that
EWarmenhoven: in gaim_plugin_init you could have:
EWarmenhoven:
if (blist) {
do_the_normal_thing();
} else {
gaim_signal_connect(handle, event_signon, now_the_buddy_list_is_here, NULL);
}
EWarmenhoven: and actually, that's the way it should be for all plugins that
modify the buddy list, because there will be at least one point during
execution that it could be loaded when the person is signed off (and i'm not
talking about when they first start it up, i'm talking about when they choose
'sign off' instead of 'close' in the buddy list menu)
committer: Tailor Script <tailor@pidgin.im>
author | Eric Warmenhoven <eric@warmenhoven.org> |
---|---|
date | Thu, 20 Apr 2000 00:12:58 +0000 |
parents | 4cef3d250f3c |
children | 91d3dfac9c6e |
line wrap: on
line source
%define name gaim %define version 0.9.14 %define release 1 %define prefix /usr Summary: A client compatible with AOL's 'Instant Messenger' Name: %{name} Version: %{version} Release: %{release} Group: Applications/Internet Copyright: GPL Url: http://marko.net/gaim Packager: rflynn@blueridge.net Source: ftp://ftp.marko.net/pub/gaim/gaim-%{version}.tar.gz Buildroot: /var/tmp/%{name}-%{version}-%{release}-root %description Gaim allows you to talk to anyone using AOL's Instant Messenger service (you can sign up at http://www.aim.aol.com). It uses the TOC version of the AOL protocol, so your buddy list is stored on AOL's servers and can be retrieved from anywhere. It contains many of the same features as AOL's IM client while at the same time incorporating many new features. %prep %setup %build CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix} make %install if [ -d $RPM_BUILD_ROOT ]; then rm -r $RPM_BUILD_ROOT; fi mkdir -p $RPM_BUILD_ROOT%{prefix} make prefix=$RPM_BUILD_ROOT%{prefix} install-strip %files %defattr(-,root,root) %attr(755,root,root) %{prefix}/bin/gaim %doc doc/the_penguin.txt doc/PROTOCOL doc/CREDITS NEWS COPYING AUTHORS doc/FAQ README ChangeLog %clean rm -r $RPM_BUILD_ROOT