diff debian/gftp-text.postinst @ 400:398fcbad832b

2004-2-15 Brian Masney <masneyb@gftp.org> * debian/changelog debian/copyright debian/gftp-text.postinst debian/gftp-text.prerm - updated Debian packaging files from Aurelien Jarno <aurelien@aurel32.net>
author masneyb
date Sun, 15 Feb 2004 18:07:08 +0000
parents f7251c70153a
children 2311d02b07bc
line wrap: on
line diff
--- a/debian/gftp-text.postinst	Sun Feb 15 17:53:34 2004 +0000
+++ b/debian/gftp-text.postinst	Sun Feb 15 18:07:08 2004 +0000
@@ -1,6 +1,27 @@
 #!/bin/sh
+# postinst script for gftp-text
+
+set -e
+
+case "$1" in
+        configure|abort-upgrade)
+                update-alternatives --install /usr/bin/ftp ftp /usr/bin/gftp-text 100 \
+		                    --slave /usr/share/man/man1/ftp.1.gz ftp.1.gz /usr/share/man/man1/gftp.1.gz
 
-update-alternatives \
-        --install /usr/bin/ftp ftp /usr/bin/gftp-text 100 \
-        --slave /usr/share/man/man1/ftp.1.gz ftp.1.gz /usr/share/man/man1/gftp.1.gz
+        ;;
+        abort-remove|abort-deconfigure)
+        ;;
+        *)
+                echo "postinst called with unknown argument \`$1'" >&2
+                exit 1
+        ;;
+esac
 
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+