comparison bitstream.c @ 9431:932543edc1d2 libavcodec

Rename pbBufPtr() to put_bits_ptr(). The new name is more readable and consistent with the FFmpeg naming style.
author stefano
date Mon, 13 Apr 2009 16:59:38 +0000
parents 0dce4fe6e6f3
children f3ff182e9ecf
comparison
equal deleted inserted replaced
9430:e806d2145e72 9431:932543edc1d2
89 for(i=0; i<words; i++) put_bits(pb, 16, AV_RB16(&srcw[i])); 89 for(i=0; i<words; i++) put_bits(pb, 16, AV_RB16(&srcw[i]));
90 }else{ 90 }else{
91 for(i=0; put_bits_count(pb)&31; i++) 91 for(i=0; put_bits_count(pb)&31; i++)
92 put_bits(pb, 8, src[i]); 92 put_bits(pb, 8, src[i]);
93 flush_put_bits(pb); 93 flush_put_bits(pb);
94 memcpy(pbBufPtr(pb), src+i, 2*words-i); 94 memcpy(put_bits_ptr(pb), src+i, 2*words-i);
95 skip_put_bytes(pb, 2*words-i); 95 skip_put_bytes(pb, 2*words-i);
96 } 96 }
97 97
98 put_bits(pb, bits, AV_RB16(&srcw[words])>>(16-bits)); 98 put_bits(pb, bits, AV_RB16(&srcw[words])>>(16-bits));
99 } 99 }