comparison mpegaudioenc.c @ 9431:932543edc1d2 libavcodec

Rename pbBufPtr() to put_bits_ptr(). The new name is more readable and consistent with the FFmpeg naming style.
author stefano
date Mon, 13 Apr 2009 16:59:38 +0000
parents 4cb7c65fc775
children c78fd9154378
comparison
equal deleted inserted replaced
9430:e806d2145e72 9431:932543edc1d2
779 init_put_bits(&s->pb, frame, MPA_MAX_CODED_FRAME_SIZE); 779 init_put_bits(&s->pb, frame, MPA_MAX_CODED_FRAME_SIZE);
780 780
781 encode_frame(s, bit_alloc, padding); 781 encode_frame(s, bit_alloc, padding);
782 782
783 s->nb_samples += MPA_FRAME_SIZE; 783 s->nb_samples += MPA_FRAME_SIZE;
784 return pbBufPtr(&s->pb) - s->pb.buf; 784 return put_bits_ptr(&s->pb) - s->pb.buf;
785 } 785 }
786 786
787 static av_cold int MPA_encode_close(AVCodecContext *avctx) 787 static av_cold int MPA_encode_close(AVCodecContext *avctx)
788 { 788 {
789 av_freep(&avctx->coded_frame); 789 av_freep(&avctx->coded_frame);