diff configure.ac @ 29410:6288bbd53f44

Pass around a va_list instead of a pointer to a va_list. Refs #7404 This gets rid of a compile warning for me on x86_64. I don't have an i386 box to test on, but every bit of evidence I can find tells me that it's totally fine to pass around a va_list. We do it in status.c If this breaks compilation for you or you get a warning from perl-handlers.c then pleaes let me know! Or just disapprove this
author Mark Doliner <mark@kingant.net>
date Wed, 10 Feb 2010 09:04:15 +0000
parents 1b040b79da38
children d77ecfe2b2c9 1eeeb20f0b9f 5dec9d90fb51 1e4781fb144b
line wrap: on
line diff
--- a/configure.ac	Wed Feb 10 07:09:52 2010 +0000
+++ b/configure.ac	Wed Feb 10 09:04:15 2010 +0000
@@ -2393,30 +2393,6 @@
         AC_DEFINE(HAVE_TM_GMTOFF, 1, [Define if you have a tm_gmtoff member in struct tm])
 fi
 
-AC_CACHE_CHECK([whether va_lists can be copied by value], ac_cv_va_val_copy,[
-	AC_TRY_RUN([#include <stdarg.h>
-#include <stdlib.h>
-	void f (int i, ...) {
-	va_list args1, args2;
-	va_start (args1, i);
-	args2 = args1;
-	if (va_arg (args2, int) != 42 || va_arg (args1, int) != 42)
-	  exit (1);
-	va_end (args1); va_end (args2);
-	}
-	int main() {
-	  f (0, 42);
-	  return 0;
-	}],
-	[ac_cv_va_val_copy=yes],
-	[ac_cv_va_val_copy=no],
-	[ac_cv_va_val_copy=yes])
-])
-
-if test "x$ac_cv_va_val_copy" = "xno"; then
-	AC_DEFINE(VA_COPY_AS_ARRAY, 1, ['va_lists' cannot be copied as values])
-fi
-
 dnl #######################################################################
 dnl # Check for check
 dnl #######################################################################