Mercurial > pidgin
view plugins/mono/MPlugin.cs @ 13212:64bae3cbec8d
[gaim-migrate @ 15576]
Mostly documentation. Is there any reason the if statement was
written the way it was? This seems more clear to me.
Also, gaim_buffer.c doesn't seem like the best name for this. I
mean, it's a part of Gaim, does it really need "gaim" in the filename?
circbuffer.c seems better to me. Anyone else have an opinion?
Because you're wrong. No, just kidding.
committer: Tailor Script <tailor@pidgin.im>
author | Mark Doliner <mark@kingant.net> |
---|---|
date | Fri, 10 Feb 2006 06:07:19 +0000 |
parents | 67fbd2ff4c4e |
children |
line wrap: on
line source
using Gaim; public class MPlugin : GaimPlugin { public void HandleSig(object[] args) { Buddy buddy = (Buddy)args[0]; Status old_status = (Status)args[1]; Status status = (Status)args[2]; Debug.debug(Debug.INFO, "mplug", "buddy " + buddy.Name + " went from " + old_status.Id + " to " + status.Id + "\n"); } public override void Load() { Debug.debug(Debug.INFO, "mplug", "loading...\n"); /*Signal.connect(BuddyList.GetHandle(), this, "buddy-away", new Signal.Handler(HandleSig));*/ BuddyList.OnBuddyStatusChanged.connect(this, new Signal.Handler(HandleSig)); } public override void Unload() { Debug.debug(Debug.INFO, "mplug", "unloading...\n"); } public override void Destroy() { Debug.debug(Debug.INFO, "mplug", "destroying...\n"); } public override GaimPluginInfo Info() { return new GaimPluginInfo("C# Plugin", "0.1", "Test C# Plugin", "Longer Description", "Eoin Coffey", "urled"); } }